using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[(?:[^[\]]*?)\]\s*?(?=\[))|(\[(?:[^[\]]*?)\](?!\s*[\|&]\s*.))|(?:\[[^[\]]*?])|([^&\|\s]+)\s+(?=[^&\|\s]+)";
string input = @"[uname!uname] [uname!uname] | [submission_name !CustomValue] | [uname!uname] [submission_name!CustomValue] [uname> colin] 7 3&dsa | asf as d | [143 & t] | d d d";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}