$re = '/(\[(?:[^[\]]*?)\]\s*?(?=\[))|(\[(?:[^[\]]*?)\](?!\s*[\|&]\s*.))|(?:\[[^[\]]*?])|([^&\|\s]+)\s+(?=[^&\|\s]+)/';
$str = '[uname!uname] [uname!uname] | [submission_name !CustomValue] | [uname!uname] [submission_name!CustomValue] [uname> colin] 7 3&dsa | asf as d | [143 & t] | d d d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);