package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[P]\W`)
var str = `P=0.0658
P>0.05
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}