import re
regex = re.compile(r"^([0-3]{1}?[0-9]{1})(\/|-)([0-1]{1}?[0-9]{1})(\/|-)([1-2]{1}[0-9]{3})( |-| - )([1-9]{1}[0-9]{1}|[0-2]{1}[0-9]{1}):([0-5]{1}?[0-9]{1}):([0-5]{1}?[0-9]{1})$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("13/08/2015 15:07:01\n"
"13/08/2015-15:07:01\n"
"13/08/2015 - 15:07:01\n"
"01/01/2015 - 11:00:00\n"
"01/01/2015 - 22:10:55")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")