re = /(?:\d+\.)+([^\s]*)(?:\.\d+)+/
str = '09.04.EXAMPLETEXT.14 test 09.04.EXAMPLETEXT.14 test 09.04.EXAMPLETEXT.14 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end