const regex = /(?<!\\)"[^"\\]*(?:\\.[^"\\]*)*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\\)"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"', 'gm')
const str = `"first | last | name" |" john | white "| age | 52
school |" ABC | USA "| year | 2016
Home | Road | year\\" | 1989\\"
company |" Pvt | ltd "| joining | 2019
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}