#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{0,10}?(\.)?(\d{1,2})?$"
Local $sString = "123" & @CRLF & _
"12345678901" & @CRLF & _
"1234567890.00" & @CRLF & _
"111.12" & @CRLF & _
"123455" & @CRLF & _
".90" & @CRLF & _
".0" & @CRLF & _
"." & @CRLF & _
".900" & @CRLF & _
"1234567890" & @CRLF & _
"1234567890.1" & @CRLF & _
"1234567890.90" & @CRLF & _
"" & @CRLF & _
"111.12" & @CRLF & _
"123455" & @CRLF & _
".90" & @CRLF & _
".900" & @CRLF & _
"" & @CRLF & _
"1234567890.00" & @CRLF & _
"12345678901.90" & @CRLF & _
"123456789011" & @CRLF & _
"1234567890111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")