use strict;
my $str = '123
12345678901
1234567890.00
111.12
123455
.90
.0
.
.900
1234567890
1234567890.1
1234567890.90
111.12
123455
.90
.900
1234567890.00
12345678901.90
123456789011
1234567890111';
my $regex = qr/^\d{0,10}?(\.)?(\d{1,2})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}