// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.+[,]+\n)").unwrap();
let string = "Dear sir,
Thanks for your interest.
";
let substitution = "\\n$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}