$re = '/^\d+-[[:alnum:]]+-[[:alnum:]]+_[[:alnum:]]{3}_[[:alnum:]]{3,17}_[[:alnum:]]{3,17}(_[[:alnum:]\s]{3,20})?(_[[:alnum:]\s]{3,50})?$/m';
$str = '12345-XX-XXXXXXXX_two_three_four_fi
12345-XX-XXXXXXXX_two_three_four
12345-XX-XXXXXXXX_two_three_fourtooloooooooong
12345-XX-XXXXXXXX_two_three_four_five
12345-XX-XXXXXXXX_two_three_four_five_six
12345-XX-XXXXXXXX_two_three_four_value five
12345-XX-XXXXXXXX_two_three_four_value five_value six
12345-XX-XXXXXXXX_two_three_four_512345678901234567890_six
12345-XX-XXXXXXXX_two_three_four_five_612345678901234567890123456789012345678901234567890
3-Abc-Def_Va2_ValueNumber3_ValueNumber4_ValueNumber5_ValueNumber6
mary had a little lamb 12345-XX-XXXXXXXX_two_three_four and it was delicious';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);