use strict;
my $str = '<img src=\' \' onclick="window.open (\'http://www.viidii.info/?http://ww3______sinaimg______cn/large/bd698b0fjw1ev9gjrevg2g20a505pu0x______gif&z\'); />
<a href="ww3______sinaimg______cn" > aaa</a>
';
my $regex = qr/(<[^<>]*?ww3______sinaimg______cn[^<>]*?\/\s*?>|<a[^<>]*?ww3______sinaimg______cn.+?>.+?<\/a>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}