$re = '/(<[^<>]*?ww3______sinaimg______cn[^<>]*?\/\s*?>|<a[^<>]*?ww3______sinaimg______cn.+?>.+?<\/a>)/';
$str = '<img src=\' \' onclick="window.open (\'http://www.viidii.info/?http://ww3______sinaimg______cn/large/bd698b0fjw1ev9gjrevg2g20a505pu0x______gif&z\'); />
<a href="ww3______sinaimg______cn" > aaa</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);