$re = '/Military\n\s+([0-9,]+)\n\s+\+([0-9.]+)% Magic Effectiveness Rune Production\n\s+([0-9,]+)/';
$str = '                    Military
                    914,519
                    +97.5% Magic Effectiveness Rune Production
                    0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);