using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:'|\s?\b\w+\b\s?)(?!'s)";
string substitution = @"";
string input = @"Watch Sidney's video ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}