#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a\s+(?:[^>]*?\s+)?href=["']([^"']*)['"]"
Local $sString = "sdjhfjksdf" & @CRLF & _
"a=b sf sf sdf sf sdf http://sdjhfjksdf" & @CRLF & _
"http://sdjhfjksdf.com/" & @CRLF & _
"https://sdjhfjksdf.com.ru" & @CRLF & _
" <a href="dfgdf dfg dfgya.ru">" & @CRLF & _
"<a href='https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd'>test</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")