package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a\s+(?:[^>]*?\s+)?href=["']([^"']*)['"]`)
var str = `sdjhfjksdf
a=b sf sf sdf sf sdf http://sdjhfjksdf
http://sdjhfjksdf.com/
https://sdjhfjksdf.com.ru
<a href="dfgdf dfg dfgya.ru">
<a href='https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd'>test</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}