use strict;
my $str = 'sdjhfjksdf
a=b sf sf sdf sf sdf http://sdjhfjksdf
http://sdjhfjksdf.com/
https://sdjhfjksdf.com.ru
<a href="dfgdf dfg dfgya.ru">
<a href=\'https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd\'>test</a>';
my $regex = qr/<a\s+(?:[^>]*?\s+)?href=["']([^"']*)['"]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}