using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ASP\.NET_SessionId=[a-z0-9]*[^a-z0-9;][^;]*;\s*";
string substitution = @"";
string input = @"PortalAlias=Portal; Language_PostPortal=en-US; ASP.NET_SessionId=opn4y4n1qja0mtzm4sx4514'or+1=1--; portalroles=50FA411EBBAC79";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}