import Foundation
let pattern = #"ASP\.NET_SessionId=[a-z0-9]*[^a-z0-9;][^;]*;\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"PortalAlias=Portal; Language_PostPortal=en-US; ASP.NET_SessionId=opn4y4n1qja0mtzm4sx4514'or+1=1--; portalroles=50FA411EBBAC79"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)