#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\s\w]+?-\s*[A-Z]{2}(?=<\/div>)"
Local $sString = "<div class="endereco-item">" & @CRLF & _
" <h2 class="azulclaro identify">Casa</h2>" & @CRLF & _
" <div class="entrelinha_0"></div>" & @CRLF & _
" <div class="font_15"></div>" & @CRLF & _
" <div class="font_15"></div>" & @CRLF & _
" <div class="font_15">R: Antonio Pires dos Santos, 647 praça central</div>" & @CRLF & _
" <div class="font_15">Parque santo antonio - Sao Paulo - SP</div>" & @CRLF & _
" <div class="font_15">CEP: 55555-555</div>" & @CRLF & _
" <div class="font_15">Fone: (11)943-056-295 (55)555-555-555</div>" & @CRLF & _
" <div id="ctl00_Body_rptEnderecos_ctl00_dvRadio" class="font_15 custom-checkbox">" & @CRLF & _
" <input type="radio" id="radio0" name="radioSelect" checked onclick="setPrincipal(0)" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")