using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s\w]+?-\s*[A-Z]{2}(?=<\/div>)";
string input = @"<div class=""endereco-item"">
<h2 class=""azulclaro identify"">Casa</h2>
<div class=""entrelinha_0""></div>
<div class=""font_15""></div>
<div class=""font_15""></div>
<div class=""font_15"">R: Antonio Pires dos Santos, 647 praça central</div>
<div class=""font_15"">Parque santo antonio - Sao Paulo - SP</div>
<div class=""font_15"">CEP: 55555-555</div>
<div class=""font_15"">Fone: (11)943-056-295 (55)555-555-555</div>
<div id=""ctl00_Body_rptEnderecos_ctl00_dvRadio"" class=""font_15 custom-checkbox"">
<input type=""radio"" id=""radio0"" name=""radioSelect"" checked onclick=""setPrincipal(0)"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}