use strict;
my $str = '<div class="endereco-item">
<h2 class="azulclaro identify">Casa</h2>
<div class="entrelinha_0"></div>
<div class="font_15"></div>
<div class="font_15"></div>
<div class="font_15">R: Antonio Pires dos Santos, 647 praça central</div>
<div class="font_15">Parque santo antonio - Sao Paulo - SP</div>
<div class="font_15">CEP: 55555-555</div>
<div class="font_15">Fone: (11)943-056-295 (55)555-555-555</div>
<div id="ctl00_Body_rptEnderecos_ctl00_dvRadio" class="font_15 custom-checkbox">
<input type="radio" id="radio0" name="radioSelect" checked onclick="setPrincipal(0)" />';
my $regex = qr/[\s\w]+?-\s*[A-Z]{2}(?=<\/div>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}