const regex = /RM\*ACEHV1-(?:[A-Z]{3})?(\d*(?:\.\d*)?)(?:.*)?(-.*)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('RM\\*ACEHV1-(?:[A-Z]{3})?(\\d*(?:\\.\\d*)?)(?:.*)?(-.*)?', 'g')
const str = `RM*ACEHV1-10.00-LA
RM*ACEHV1-EUR10.00-asdf-LA
RM*ACEHV1-EUR4321.12LALA-LA
RM*ACEHV1-12-LA
RM*ACEHV1-10.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}