use strict;
my $str = '<p class="p">test</p>';
my $regex = qr/(<p.*?>.*?<\/p>)/ip;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";