using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^(?=.*\bmeat\b)(?=.*\bpasta\b)(?=.*\bdinner\b).+";
        string input = @"hello meat pasta dinner what?";
        
        Match m = Regex.Match(input, pattern);
        Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
    }
}