// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^127\.\d{1,3}\.\d{1,3}\.\d{1,3}(\:\d+)?$").unwrap();
let string = "127.1.1.1:4000
127.12.12.12
127.0.0.2:599595
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}