package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).+? (?<name>.+?) \((?<points>\d+) points?\)\n\n(?<description>.*?)\nEdit\nClone\nRemove\n`)
var str = `2. Unit test (2 points)
Test checkCharacter("word", 3).equals("Character 'd' is a letter")
Edit
Clone
Remove
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}