import Foundation
let pattern = #"(?<=(|G|M|K|h|da|d|c|m|u|n))(?=(m|g|s|A|K|mol|cd)\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
G, M, k, h, da, d, c, m, u, n
m, g, s, A, K, mol, cd
132mmol
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)