#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\.){3}(?2)$"
Local $sString = "300.300.200.100" & @CRLF & _
"12.54.255.254" & @CRLF & _
"55.19.16.56." & @CRLF & _
"55.19.01.1" & @CRLF & _
"12.54.56.56"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")