#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?:^\[//\]:[^(]+\(\K" & @CRLF & _
"|" & @CRLF & _
"\G(?!\A)\|" & @CRLF & _
")" & @CRLF & _
"(\w+):([\w,]+)"
Local $sString = "[//]: # (POST:28|USERS:102,78,90)" & @CRLF & _
"some other markdown here" & @CRLF & _
"### as well as here ###"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")