import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\[//\\]:[^(]+\\(\\K\n"
+ "|\n"
+ "\\G(?!\\A)\\|\n"
+ ")\n"
+ "(\\w+):([\\w,]+)";
final String string = "[//]: # (POST:28|USERS:102,78,90)\n"
+ "some other markdown here\n"
+ "### as well as here ###";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}