// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{([^{}]*)\|album}").unwrap();
let string = "{beethoven|artist}'s {piano sonata number twenty-three|track}
{bach|artist}'s {cello preludes|track}
{beethoven|artist}'s {opus fifty-seven sonata|track}
{bach|artist}'s {cello preludes|track} performed by {yo-yo ma|artist}
{Bulgarian womens choir|album} ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}