$re = '/\((?:[^()]++|(?R))*\)/';
$str = 'MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))
MNO(A=(B=C) D=(E=F))
MNO
RAX.MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))
RAX.MNO(A=(B=C) D=(E=F))
RAX.MNO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);