import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*hoge\\.com(\\/sp)?\\/index\\.html\\?(.*&)?ref=camp_cat(&.*)?$";
final String string = "https://hoge.com/index.html?q=qiita&ref=camp_cat&y=2016&m=05";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}