const regex = /^.*hoge\.com(\/sp)?\/index\.html\?(.*&)?ref=camp_cat(&.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*hoge\\.com(\\\/sp)?\\\/index\\.html\\?(.*&)?ref=camp_cat(&.*)?$', 'gm')
const str = `https://hoge.com/index.html?q=qiita&ref=camp_cat&y=2016&m=05`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}