const regex = /^[^\t\n]*\t(?P<host_ip>[^\t]+)[^\t\n]*\t(?P<username>[a-z]+_[a-z]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\t\\n]*\\t(?P<host_ip>[^\\t]+)[^\\t\\n]*\\t(?P<username>[a-z]+_[a-z]+)', '')
const str = `Jan 21 14:42:20 10.0.0.0 user ssh 10.0.0.0 stop task_id=460864 service=shell priv-lvl=15 start_time=1453408940 timezone=UTC cmd=exit <cr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}