re = /^[^\t\n]*\t(?P<host_ip>[^\t]+)[^\t\n]*\t(?P<username>[a-z]+_[a-z]+)/
str = 'Jan 21 14:42:20 10.0.0.0 user ssh 10.0.0.0 stop task_id=460864 service=shell priv-lvl=15 start_time=1453408940 timezone=UTC cmd=exit <cr>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end