#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\d{11}"
Local $sString = "1100582367|SDFDSFDSFDSFDSFDF" & @CRLF & _
"GBC213WREW|RWEFSDFSDF" & @CRLF & _
"1100582377|DSFDSFDSFDSF" & @CRLF & _
"2NDG.S.D" & @CRLF & _
"BIKADSFDSFDSFNO.421" & @CRLF & _
"1100582387|SDFSDFSDFDSF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")