using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{11}";
string input = @"1100582367|SDFDSFDSFDSFDSFDF
GBC213WREW|RWEFSDFSDF
1100582377|DSFDSFDSFDSF
2NDG.S.D
BIKADSFDSFDSFNO.421
1100582387|SDFSDFSDFDSF";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}