import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<string>(.*?)<\\/string>";
final String string = "<map>\n"
+ " <entry>\n"
+ " <string>id</string>\n"
+ " <string>555</string>\n"
+ " </entry>\n"
+ " <entry>\n"
+ " <string>label</string>\n"
+ " <string>Need This Value</string>\n"
+ " </entry>\n"
+ " <entry>\n"
+ " <string>key</string>\n"
+ " <string>748</string>\n"
+ " </entry>\n"
+ "</map>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}