#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<string>id<\/string>|<string>\d+<\/string>|<string>label<\/string>|<string>(.*?)<\/string>"
Local $sString = "<map>" & @CRLF & _
" <entry>" & @CRLF & _
" <string>id</string>" & @CRLF & _
" <string>555</string>" & @CRLF & _
" </entry>" & @CRLF & _
" <entry>" & @CRLF & _
" <string>label</string>" & @CRLF & _
" <string>Need This Value</string>" & @CRLF & _
" </entry>" & @CRLF & _
" <entry>" & @CRLF & _
" <string>key</string>" & @CRLF & _
" <string>748</string>" & @CRLF & _
" </entry>" & @CRLF & _
"</map>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")