const regex = /(((http(s)?:\/\/)|(\/))[0-9a-zA-Z_\/\s\ \?\.\:\;\&\=\-\@\%\!\,ùéòàèì\#\|] )?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((http(s)?:\\\/\\\/)|(\\\/))[0-9a-zA-Z_\\\/\\s\\ \\?\\.\\:\\;\\&\\=\\-\\@\\%\\!\\,ùéòàèì\\#\\|] )?', 'g')
const str = `/?vw=struttura&id=9`;
const subst = `<span class="">\0</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);