// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.*?).([a-z]+)\[([0-9]+)|:([0-9]+)]").unwrap();
let string = "Server: firesideweb01:8002
Uptime: 10:56:19
=== Address Service ===
Build Number : 2381
Database Date : 2015-07-15
Database Expiration Date: 10-31-2015
License Expiration Date : 2016-05-03
Validate Calls: 395224
Valid : 178993
Invalid : 216231
Format
Short : 358570
Long : 36654
Auto : 0
=== Name Service ===
Build Number : 2381
Database Date : 2015-06-15
Database Expiration Date: 2015-12-15
License Expiration Date : 2016-05-03
Normalize Calls: 0
IsMatch Calls : 0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}