^start of string
Group 1([s|S][e|E][l|L][e|E][c|C][t|T]) sthe literal s (11510 / 1638 / 7316) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Sthe literal S (8310 / 1238 / 5316) (case sensitive)
ethe literal e (10110 / 1458 / 6516) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Ethe literal E (6910 / 1058 / 4516) (case sensitive)
lthe literal l (10810 / 1548 / 6C16) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Lthe literal L (7610 / 1148 / 4C16) (case sensitive)
ethe literal e (10110 / 1458 / 6516) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Ethe literal E (6910 / 1058 / 4516) (case sensitive)
cthe literal c (9910 / 1438 / 6316) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Cthe literal C (6710 / 1038 / 4316) (case sensitive)
tthe literal t (11610 / 1648 / 7416) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Tthe literal T (8410 / 1248 / 5416) (case sensitive)
\sany whitespace character
Group 2([a-zA-Z0-9\-_]+|\*) 1st Alternative[a-zA-Z0-9\-_]+ Character Class[a-zA-Z0-9\-_]+ +matches at least one character from the set below:
a-zone character from a (9710) to z (12210) (case sensitive)
A-Zone character from A (6510) to Z (9010) (case sensitive)
0-9one character from 0 (4810) to 9 (5710)
\-the literal - (4510 / 558 / 2D16)
_the literal _ (9510 / 1378 / 5F16)
\*the literal * (4210 / 528 / 2A16)
,?optionally matches the literal , (4410 / 548 / 2C16)
Group 3([a-zA-Z0-9\-_]+)* *repeats the group contents below any number of times:
Character Class[a-zA-Z0-9\-_]+ +matches at least one character from the set below:
a-zone character from a (9710) to z (12210) (case sensitive)
A-Zone character from A (6510) to Z (9010) (case sensitive)
0-9one character from 0 (4810) to 9 (5710)
\-the literal - (4510 / 558 / 2D16)
_the literal _ (9510 / 1378 / 5F16)
\sany whitespace character
Group 4([f|F][r|R][o|O][m|M]) fthe literal f (10210 / 1468 / 6616) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Fthe literal F (7010 / 1068 / 4616) (case sensitive)
rthe literal r (11410 / 1628 / 7216) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Rthe literal R (8210 / 1228 / 5216) (case sensitive)
othe literal o (11110 / 1578 / 6F16) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Othe literal O (7910 / 1178 / 4F16) (case sensitive)
mthe literal m (10910 / 1558 / 6D16) (case sensitive)
|the literal | (12410 / 1748 / 7C16)
Mthe literal M (7710 / 1158 / 4D16) (case sensitive)
\sany whitespace character
Character Class[a-zA-Z0-9\-_]+ +matches at least one character from the set below:
a-zone character from a (9710) to z (12210) (case sensitive)
A-Zone character from A (6510) to Z (9010) (case sensitive)
0-9one character from 0 (4810) to 9 (5710)
\-the literal - (4510 / 558 / 2D16)
_the literal _ (9510 / 1378 / 5F16)
,?optionally matches the literal , (4410 / 548 / 2C16)
Group 6([a-zA-Z0-9\-_]+)* *repeats the group contents below any number of times:
Character Class[a-zA-Z0-9\-_]+ +matches at least one character from the set below:
a-zone character from a (9710) to z (12210) (case sensitive)
A-Zone character from A (6510) to Z (9010) (case sensitive)
0-9one character from 0 (4810) to 9 (5710)
\-the literal - (4510 / 558 / 2D16)
_the literal _ (9510 / 1378 / 5F16)
.*any character (except for line terminators), repeated any number of times
;the literal ; (5910 / 738 / 3B16)
$end of string, or before its final line terminator