$re = '/\/(\d+)/m';
$str = 'http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158
http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158?page=2
http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158?page=2/
http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158Bombe
zeichenkette005415zeichenkette';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);