use strict;
my $str = 'Mi nombre es Rodrigo Polo y mi telefono es +502 5587-1153 o tambien el (502) 5587-1153 o el 502-55871152 o el 55871153 o el (502) 55871153 o 50255871153 ';
my $regex = qr/\W(\d{3})?\W?(\d{4})\W?(\d{4})\W/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}