re = /\W(\d{3})?\W?(\d{4})\W?(\d{4})\W/
str = 'Mi nombre es Rodrigo Polo y mi telefono es +502 5587-1153 o tambien el (502) 5587-1153 o el 502-55871152 o el 55871153 o el (502) 55871153 o 50255871153 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end