import Foundation
let pattern = #"\W(\d{3})?\W?(\d{4})\W?(\d{4})\W"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Mi nombre es Rodrigo Polo y mi telefono es +502 5587-1153 o tambien el (502) 5587-1153 o el 502-55871152 o el 55871153 o el (502) 55871153 o 50255871153 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)