re = /[^\x00-\x7F]/m
str = '2022-06-20 11:16:10,381 INFO [APP] log in : 38773763@#123@دالكي '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end