use strict;
my $str = '"Some string"';
my $regex = qr/[\p{Cc}\d\p{P}\s„““”"]+/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";